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CES Project Setup Checklist: 
 

1) Ensure the Spec Year is set to 10. 

2) Set the Unit System to ENGLISH. 

3) Set the Base Date to the LETTING FINISH DATE from SPMS. 

4) Set the Work Type to the HIGHEST level of summarization (“000” level) for the project type. 
(e.g. “A000” for a bridge project, “P000” for an intersection improvement, etc.) 

5) Set the Bid-Based Inflation Radio Button to “USE MODEL” if the project is to be constructed 
within the current year or to USE JOB if the project is to be constructed in a future year. 

6) Ensure that the Inflation Percent and the Years Until Work entries are correct.  These values 
were imported from SPMS when the CES job record was created and may be obsolete. 

7) Set the Season to the time of year when the job is to be CONSTRUCTED (Winter, Spring, 
Summer, or Fall). 

8) Set the Locations to the COUNTY and DISTRICT where the job is located. 

9) Choose the default Item Bid History Library that is appropriate for the Contract Type (B, M, R, 
RS, T). 

10) Make sure you enter the Latitude and Longitude of the project midpoint on page 2 of the 
General tab. 

11) If you have any problems or issues using CES, send an email to cessupport@indot.in.gov. 
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BASIC INSTRUCTIONS FOR USING CES 

Setting up the Project Estimate 
 
To get started click on the green money bag in the top left corner. 
 

 
 
Find the project in the list and click once to select. 
 

 
 
To correct the Spec Year (if necessary), choose Edit, then Change Spec Year.  The Spec Year should 
always be "10" 
 

 

Click Here 
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Once the Spec Year is correct, double click on the Job Number to open the job file. Make sure the 
correct Unit System is selected and check the Classification and Location fields on page 1 for accuracy.  
The Work Type should be set to the highest level of summarization (000 level).  The Job Type should be 
set to the detailed work type for the project. 
 

 
 
 
Set the Inflation % to the annual percentage inflation rate desired, and the Years Until Work to the 
number of years between the current date and the beginning of construction.  The Base Date should 
be set to the date for which you want CES to produce pricing, which should be the Letting Date under 
normal circumstances.  
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Under Bid Histories, first click on the Arrow to 
the right of the Cost Grp Hist (Cost Group 
History) field and select the STANDARD cost 
group bid History from in the popup window 
and click OK 
 
 
Note:  This step is only necessary if you plan on 
using the Parametric Estimating Features 
 
 
Next click on the arrow to the right of the Item 
History field. 
 
Select the appropriate Item Bid History Library 
and click OK.  Use ALL CONTRACTS – 3 YEARS 
bid history library unless you have reason to 
believe that that there are special conditions 
which warrant the use of the one year, two 
year, or contract type-specific Bid History 
Libraries 
 
 
Set the Bid-based Inflation radio buttons to either Use 
Model or Use Job.  If you choose Use Model inflation will 
be calculated and applied to bid-based prices only based 
on the Base Date for the job.  If you choose Use Job an 
inflation adjustment will be applied to the entire Job by 
inflating the total cost by the inflation rate specified by the 
Inflation % for the number of year specified in the Years 
Until Work. 
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The last things you need to do on page 1 are to set the anticipated construction season from the pull 
down menu next to Season and enter the project metrics: Pavement Depth, Length, Width, and Lane 
Miles/Kilometers.  
 
This information should be entered on page one of the General tab in the block at the bottom left 
titled Metrics.  English units should be used for english projects, metric units should be used for metric 
projects.  All entries should be rounded to two decimal places as appropriate. 
 

a. The Project Length is the overall length of pavement, entered in miles (kilometers). 

b. The Pavement Width is the total width of new mainline pavement, excluding paved 
shoulders, entered in feet (meters) 

c. The Pavement Depth is the average depth of new mainline pavement, excluding paved 
shoulders, entered in inches (millimeters). 

d. Lane Miles (kilometers) is the project centerline length times the number of through travel 
lanes entered in miles (kilometers). 

Next select the radio button for page 2.  On page 2 enter the Latitude and Longitude in degrees, 
minutes, seconds without symbols or other punctuation.  The String 2 field is for the person checking 
the estimate and the Date 2 field is for the date the estimate was checked.  Date 1 is reserved for the 
letting date and Date 3 is reserved for the RFC date.  Page 2 is also where you can set or reset the 
Control Group.  
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Deactivating Cost Groups 
 
Next, click the Cost Groups tab. Cost Groups are only used for Parametric Estimating.  Make sure all 
the boxes under Active?, are unchecked.  If the box is checked, simply click on the check to remove it.  
The total amount of any item checked on this tab will be added to your estimate. 
 

 
 

Entering & Updating Project Categories 
 
Next, click the Categories tab. The category Description should match the project work category in 
SPMS.  Each job should have one category unless you are specifically instructed otherwise.  The 
category tab is where you enter Bridge Information.  You must enter the Bridge ID, Bridge Length, 
Bridge Width, Number of Spans, and Bridge Type for each Bridge in the project.    

Click Here 
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Note:  You will be required to enter additional categories if your estimate includes alternate bridge or 
pavement designs.  See the Alternate Bidding Section for details. 
 
 
 
 

Entering Estimate Items 
 
Next, click on the Items tab and then click on the folder tree icon for the “tree view” interface. 
 
 

 

Click Here 
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To begin adding items to the estimate, right click on Items for Job and select Add Item. 
 

 
 
 
Note:  The Items for Job (root) level of the tree summarizes all of the item level price and 
inflation calculations 
  

Right Click Here 

“Tree View” Icon 
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To select an item, click on the arrow next to the Item field.  
 

 
 
 
 
 
The item list window will pop up with all the pay items. Click the Filter button to search for a specific 
item. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Click Here 

Click Here 

mailto:cessupport@indot.in.gov


INDOT CES Designer Instructions  

cessupport@indot.in.gov 
10 

To search for an item by description, select Short Description in the Column pull down menu, select 
Contains in the Operator pull down menu and type part of the item name in the Value box in ALL 
CAPS. Then click OK. This will narrow the selection within the item list window 
 

 
 
. To select an item, double click on the item or single click and select OK. The items details will now 
show up in the Item, Description, and Units fields. 
 

 
 
Next enter the Quantity in the given box.   Once you enter a quantity CES will automatically generate a 
price based on the default Task for that item and the Item History Library selected on the General Tab. 
 

Entering Estimate Item Prices 
 
Prices in CES are entered using Tasks. There are three basic types of tasks:  Bid-based tasks, Cost-based 
tasks, and Reference price tasks. 
 
Bid-based tasks use pricing models generated from historical bid data and stored in the Item History 
Library.  Bid-based pricing models may be based on a regression model or an average. 
 
Cost-based tasks build prices from cost sheets containing the material, equipment, and labor costs 
associated with constructing that item. 
 
Reference price tasks allow you to enter an ad-hoc price for each item.  There are three types of 
reference prices: 

mailto:cessupport@indot.in.gov


INDOT CES Designer Instructions  

cessupport@indot.in.gov 
11 

• Historical Reference prices use the price from the historical price field of the Item List 
• New Normal (Ad Hoc) reference prices allow you to enter a dollar price for the item. 
• New Percent On Top reference prices add the specified percentage of the item estimate to the 

total estimate. 
 
 
 

 
 
 
To enter a Reference Price task right click on the item in the box on the left, select Add, select 
Reference Price and then select New Price.  Enter the estimated cost in the Price field and hit Enter  
 
 

 
 

Right Click Here to Enter Tasks  

Enter Item Quantity Here  

Enter Estimated Cost Here 
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If you choose to enter a historical price CES will automatically enter the weighted average unit price 
from the pay item list. You may also choose to have CES calculate the price as a “Percent On Top” of 
the overall estimated cost.  If you select “Percent on Top” CES will automatically set the price of the 
item to the designated percentage of the overall estimated cost. 
 
The cost information will now show up in the Unit Price and Extended Amount fields. 
 
If you wish to enter a Bid-based price generated by one of the CES pricing model right click on the item, 
select Add and then select Bid-based Price.  CES will automatically select the model that most closely 
matches the project header information you entered on the General tab. 
 
In most cases the Unit Price and Extended Amount will automatically propagate based on the values 
from the selected Price Histories and Libraries on the General tab.  (Make sure a Quantity has been 
entered before adding a Bid-based Price.) 
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If the Unit Price does not automatically populate the current library does not contain a pricing model 
for your item.  In those cases you can either use a price from a similar item in the current library or 
look for a price for that item in another library.  To look for a price in the current library use the Library 
Items button to select a similar item from the currently selected Bid History Library. The Unit Price for 
the selected item will then be used for your item. 
 

 
 
You can also use the Library Name field to look up prices in a different Library other than the default 
library selected on the General Tab  
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If a similar item cannot be found, or the item cannot be found in another Library, right click on the Task 
ID for the bid based price and delete the entry. Then follow the steps for creating a Reference Price for 
the item and enter a price estimated from other resources.   
 
 

 
 
 
Continue entering Items and Prices until the estimate is complete. Next, click the Save disk and then 
Close the job by clicking the “X” in the upper right hand corner of the Job specific window.  
 
 

 
 
 
 
  

Right Click Here 

Click Here to SAVE Click Here to Close Job 
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Marking Non-participating items 
 
It is not normally necessary to mark the funding source for each item on your estimate.  However, 
there may be circumstances where specific items on your estimate will not be eligible to participate in 
federal funding.  You must enter a funding code for these items.  The funding code used to mark “non-
participating” items is “01Z”, which is why these are commonly referred to as “Z items”. 
 
 

 

 
 

 
Enter funding code 01Z in the “Funding Code” field  for each non-participating item.  Clicking the arrow 
button next to the field will produce a list of available funding sources.  However, it is not normally 
necessary to enter specific funding codes unless specifically instructed to do so by the project manager.   
 
Note: Funding codes may be entered in either the tree view or the grid view. 
  

Enter the Funding Code Here 
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Recalculating Item prices 
 
CES does not automatically recalculate all of the costs associated with all items on a job each time a 
change is made.  Changing an item price or quantity will only cause CES to recalculate the costs 
associated with that specific item as well as the associated totals and subtotals..  However, there may 
be instances when you may wish to recalculate your estimate in order to ensure that all of the items on 
your estimate have the most current pricing. 
 
To recalculate item prices, select the item(s) you wish to recalculate and select Recalculate Values 
from the edit menu or click the recalculate button on the tool bar.  To select multiple adjacent items 
select the first item and then hold down the SHIFT key as you select the last item.  You may also select 
multiple items by holding down the CTRL key while selecting the rows or use the standard Windows 
CTRL-A shortcut to select all items.  All of the selected rows will be highlighted.  
 
 

 
 
 
Note: You can only recalculate one item at a time in the tree view.  

Recalculate Button 
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Generating Reports 
 
To run a report, right click on the des number in the main Jobs window, select Run Process, select the 
report you wish to run and then select OK.  Next select Submit on the Confirm Process Submission 
dialog. CES will return DPS Status Monitor dialog confirming the process Profile under which the 
process has been submitted.  
 

 
 
 
 
 
 
After a few seconds, a DPS Status Monitor window will 
pop up indicating the report is complete. Select OK. 
Take note of the process Profile, you can use this to 
identify this report process in the Process Status List 
later. 
  

Right Click on Job to Run Process 
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Viewing. Printing, and Saving your Reports 
 
To view a report select Process Status from the File menu at the top left of the CES window. Locate the 
process profile you wantr and double dlick on it to view the process files.  If you have only run one 
report it should be the most recent process based on Date Submitted.  
 

 
 
 
Double Click on the report file to open it in the file viewer windows.  The report file should be the first 
text file on the list and should have a name similar to the Output.txt file in the example below. 
 
 

 
 
 
 
 
To print a report open it in the file viewer window and click the Print Report button on the bottom of 
the screen.  You can also print the report by right-clicking on the file name in the Process Status List 
window and choosing Print from the popup menu. 
 
 NOTE:  All CES reports are formatted to print in an 8-1/2 by 11 landscape orientation* 

Double Click Here 

Double Click Here 
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To save a report open the report file in the file viewer window and click the Save As Rich Text button. 
 

 
 
 
 
Save the report as an *.rtf or a *.doc file.  
 

 
 
 
NOTE:  All of the CES reports are formatted to print in an 8-1/2 by 11 landscape 
orientation with half inch margins.  You may need to adjust the page setup in your word 
processor program to display the report files properly. 
  

Click Here 
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To return to the main Jobs window, close all the Process windows by clicking the “X” in the right hand 
corner until the Jobs window is the only one open.  
 

 
 
 

Available CES Reports 
 
The Job Summary Estimate Report produces an output file named ESTIMATE.TXT that lists all items in 
your estimate including the description, supplemental description, quantity, unit, price and extension.  
It also shows whether the item is included in the standard specifications or must be defined by an 
accompanying unique or recurring special provision and flags obsolete items.  You can run it by 
choosing Generate Job Summary Estimate Report from the Run Process dialog.   
 
The Estimate Item Verification Report produces an output file named ITEM_RPT.TXT that also lists all 
items included in your estimate including the description, supplemental description, quantity, unit, 
whether the item is defined by the standard specifications or an accompanying unique or recurring 
special provision and flags obsolete items.  However, this report does not print item prices or totals.  
You can run it by choosing Estimate Item Verification Report from the Run Process dialog.   
 
The Job Detail Estimate Report produces a file named OUTPUT.TXT that includes the Job Summary 
Estimate as well as full details for all of the Cost Groups and price Tasks associated with your Estimate. 
You can run this report by choosing Generate Job Detail Estimate Report from the Run Process dialog.   
 
HINT:  You can save yourself some steps by “printing” reports directly to a .pdf file using 
a pdf file generator.* 
 
  

Click Here 
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Submitting Your Estimate with Final Tracings 
 

1. Set the Contingency Percent and Years Until Work to Zero. (This will zero out all of the inflation 
calculations) 

2. Create a snapshot of your estimate 
3. Generate the Job Summary Estimate Report. 
4. Upload the Job Summary Estimate to ERMS as an Adobe Acrobat (.pdf) file 
5. Change the CES job control Group to “12”.  
6. Save and close the CES Job (Note:  once the job is closed you will no longer have access to this estimate,) 

WARNING 
 
Once the control group is changed and saved, you will no longer have access to this CES Job! 
 

 
 
HINT:  You can save yourself a step by “printing” the Job Summary Estimate Report 
directly to a .pdf file using Adobe Acrobat or a free pdf file creation utility such as 
CutePDF.* 
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CREATING A SNAPSHOT 
A Snapshot is a complete picture of a job at a given time. Snapshots can be used to trace the evolution 
of an estimate from conception to completion and can also as a backup. The user can create a 
snapshot at any time; snapshots will also be taken automatically when certain actions (such as splitting 
a job) are taken. 
 
Select the job you wish to take a snapshot of, and select Snapshots from the View menu.   
 

 
 
Or right-click on the Job and select Snapshots from the shortcut menu. 
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The Snapshot window will open and display any snapshots that have been taken of your CES job. 
 

 
 
To open an existing snapshot, double-click on the Snapshot title or right-click on it and choose 
Snapshot from the shortcut menu.  
 
The Snapshot window looks like the regular job window but you cannot edit any of the data. 
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To add a snapshot, open the snapshot window for that contract and either choose Add from the Edit 
menu…   
 

 
 
…or you can right-click on the snapshot window itself and choose Add. 
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Enter a description for the Snapshot in the popup window and click OK. 
 

 
 
To restore project data from a snapshot, choose Import from the File menu and select Job Information 
from CES Snapshot. 
 

 
 

mailto:cessupport@indot.in.gov


INDOT CES Designer Instructions  

cessupport@indot.in.gov 
26 

 
Then select the snapshot you wish to import from the popup window. 
 

 
 
 CES will give you the option of importing some or all of the snapshot data into your job. 
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IMPORTING AN ESTIMATE INTO A CES JOB USING AN XML FILE 

Creating an XML file using Estimator® 
1) Open the Estimator file and make sure all the information is in the required fields.  

a) Estimate ID: DES # 
b) Spec Year:  10 for English, 05 for Metric 
c) Base Date:  Letting Date 
d) Unit System: E for English, M for Metric 
e) Description:  The project description. should match the description in SPMS. 

2) Make sure there is also a Group Description for each group in the estimate 
3) Select Export from the File menu. Estimator it will prompt you to select a file location.    
4) The File name should be the Estimate ID/DES number.  
5) The “Save as type” should be XML estimate file.  

Creating an XML file using Oman BidTabs ® 
1) Open the Estimate file and make sure the Bid Price Column is populated for all items 
2) Open the Project Settings and set the pay Item Sort to “Pay Item” 
3) Click on the Export to XML button on the taskbar and then choose the directory where you 

want to save the file. Two files will be created. For example, if the project was: 8915400. The 
two files will be 8915400.PLUS and 8915400.XML. 

Preparing CES to receive the Estimate 
1) Open CES 
2) Open the Jobs window 
3) Scroll or filter the job window to locate the CES Job with the same DES number as the Estimate 

you are importing.  If you cannot see the DES number, Contact CES Support to get the Estimate 
added to your Control Group.  Do NOT upload an estimate if you do not have access to the DES 
number.   

4) Set the Spec Year to the appropriate Specification Year for your Estimate if necessary. 
5) Open The CES Job and check the Items tab to see if an estimate has been uploaded already.  

Uploading the XML file into the database 
1) Select Upload File>Process I/O File from the Utilities menu  
2) Select the XML export file that you created in step one and click Open. 
3) Select the qpjiportdir directory in the  Save Process I/O file As dialog and make sure that the 

file name in the left column is the DES# followed by .XML  (Hint:  You can use the “Ctrl C” 
shortcut keys to copy this file name for use in the next step)  

4) Click Okay. 

Importing the XML file into the CES job 
1) Select Run Process from the File menu  
2) Select the Import New Projects process. 
3) Select the Estimator (Trns*Port Format) 
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4) Enter the file name for the XML import file in the appropriate field on the Import Data Options 
dialog and select the import options you desire.  The file name should be the DES number plus 
“.XML” and must be the same as the CES Job number and the Estimator Estimate ID.  If you 
copied the file name during the previous step you can paste it into the field using Ctrl V. 

5) Make sure the Group number matches the group number assigned to your organization and 
click Submit. 

6) Open the CES job and click on the Items tab.  Your items should now be in CES.  Imported prices 
will appear as Reference Prices in CES. 

7) Highlight all of the items and click the recalculate button to recalculate the estimate using the 
imported prices 

 
 

 
 

  

Select Estimator Format 
 

Import File Name 

Enter Your Control Group 
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EXPORTING A CES JOB TO AN XML FILE 
 

1) Select the Job Number you wish to export and select Run Process from the File menu (or right 
click on the  Job Number and select Run Process 

2) Select “Export Copy of Job” and click OK (A pop-up will confirm the start of the process; click OK 
to close) 

3) A second pop-up will show the process has completed, go to File; Process Status; double click 
most recent Completed process; right click on OUTPUT.txt, Save As “Project number”.xml 

4) Open Estimator and choose Import from the File menu. Select the saved .xml file, Click Open. 

RENUMBERING ESTIMATE ITEMS IN CES 
 
While CES does not have a command to automatically renumber Estimate item lines, it does have the 
ability to renumber all of the following lines when you insert an new line in the middle of an estimate.  
This process takes advantage of that feature to “fool CES into renumbering your whole estimate by 
inserting a new line one. 
  

1) Go to the CES job window Items Tab.  You must be in Grid View for this process to work. 
2) Go to the existing line #0001 and renumber it manually to 9999 (CES will automatically fix this 

later.)  This is required because CES will not accept two lines numbered 0001 
3) Sort the item list by pay item number so the lowest pay item number is on the first line, the 

next highest pay item number is on the second line, etc, etc.  Don't worry about the line 
numbers, they will be fixed later as well. 

4) Renumber the line the Second Item 0001.  
5) Delete the first line.  (It's probably going to be 105-06845, Construction Engineering, which is a 

lump sum, so it's no big hardship to delete it and recreate it, but make sure you keep careful 
notes because you're going to have to reenter this item later)  Your second item (the one you 
just renumbered as line 0001) should now become the first. 

6) Highlight that first line (The new Line 0001 you created in step 3) and click the INSERT button or 
select Insert from one of the menus.  CES will ask you if you want to renumber all lines starting 
with this one or add the new item to the bottom of the list. Choose the renumber line option.  
CES will insert a new, blank line 0001 and renumber everything else sequentially (including  the 
line 9999 you created in step 1) 

7) Re-enter your first pay item on the new line #0001. 
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Setting Up CES Estimates for Alternate Bidding 
 
Alternate bidding requires the bidder to bid at least one alternative while allowing the bidder to bid on 
any or all of the alternatives available.  
 
Alternate bidding is used when the two alternatives must be evaluated using a value adjustment that is 
not known to the bidder prior to letting. 

Category Level Alternates 
Category Level alternates are used when entire groups of items are alternates to other groups of items,  
or when the two groups of items represent alternative categories of work, such as alternate pavement 
sections (asphalt vs. concrete)  or alternate bridge designs (concrete vs. steel). 
 
Basic principles: 

o All Common Items will be in Category 0001. 
o All items related to the first alternate will be in Category 0002. 
o All items related to the second alternate will be in Category 0003.  
o Alternate sets are distinguished by three character Alternate Code where he first two 

characters are letters defining the set (AP, AB, etc) and the third character is a number 
designating the set member (1, 2, etc)  so AA1 is an alternate to AA2 and AB1 is an Alternate to 
AB2, but AA1 is not an alternate to AB2. 

o The first character of the Alternate Code must be “A” to define an alternate set. 
o CES will use the lower cost option for each alternate set when totaling the estimate.  So if your 

estimate contains more than one alternate sets the final estimate will be the cost of common 
items + the lower cost alternate of the first alternate set + the lower cost alternate of the 
second alternate set and so on. 

o The CES Estimate Item Total (as shown on reports and the item tab) will always be the total of 
all items regardless of alternate status.  The Inflated Estimate Total & Total Estimate are 
adjusted to account for alternatives as well as inflation and contingency. 

Steps: 

Create a Separate Category for Each Alternate 

Make a backup snapshot of your Job 

Open the Job and go to the “Categories” tab 
 Select Category 0001 and choose “Hide/Show Details” to expand the detail section. 
 Edit the Category Description to specify Common Items (e.g. “Road Construction – Common 

Items” or “Bridge Construction – Common Items”).    
 Leave the Alternate Code field blank to indicate that this category contains common items. 

 Select “Add” from the Edit menu to create Category 0002. 
 Edit the Category Description to specify the second alternate (e.g. “Road Construction – 

PCCP” or “Bridge Construction – Concrete”.    
 Set the Alternate Code to “AP2” for an alternate pavement or “AB2” for an alternate 

bridge.  
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 Select “Add” from the Edit menu to create Category 0003. 
 Edit the Category Description to specify the first alternate (e.g. “Road Construction – HMA” 

or “Bridge Construction – Steel”. 
 Set the Alternate Code to “AP2” for an alternate pavement or “AB2” for an alternate 

bridge. 
 

Now go to the “Items” tab and assign each item to a Category (Alternate) as necessary 

Tips for using Category-level alternates 
 All items must be assigned to a Category – either one of the alternates or to the common 

items. 
 Leave the item-level Alternate Code blank unless you are also using alternate items within a 

category. 
 You may have as many as 26 Alternate sets (AA-AZ) 
 Use mnemonic codes for alternate sets (“AP” for alternate pavement, “AB” for alternate 

bridge, “AS” for alternate subbase, etc.) when possible 
 You can have as many as nine alternate categories within each alternate set. 
 Assign the full quantities of all items needed to construct each alternate to the applicable 

alternate set.  Do not split out items between sets.  
 Assign all items common to both alternates to the common items category. 

Item Level Alternates 
Item level alternates are used when specific items on the project are considered alternates to other 
specific items, such as lamp poles. 
 
Basic principles: 

o Item level alternates will only be used when specific items are alternates to other specific 
items. 

o All alternate items must have a counterpart item or item(s).  You cannot make nothing an 
alternative to something.  

o The alternate items that receive the lowest bid prices will always be considered part of the 
awarded bid.  We cannot cherry pick alternates when awarding a contract.   

o CES will use the lower cost option when totaling the estimate. 
o Alternate sets are distinguished by three character code where he first two characters are 

letters defining the set (AP, AB, etc) and the third character is a number designating the set 
member (1, 2, etc).  So AA1 is an alternative to AA2 and AB1 is an Alternative to AB2, but AA1 is 
not an alternative to AB2 

Steps: 

Make a backup snapshot of your Job 

Open the Job and go to the “Items” tab 
 Select or enter the first item for the alternate set. 
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 Set the Item Alt Code to indicate that this is the first alternate in the alternate set  (e.g. 
“AA1”) 

 Select or enter the alternative item in the Alternate set  
 Set the Item Alt Code to indicate that this is the alternative item within the alternate set 

(e.g “AA2) 
 Continue until you have designated all alternate items 

Tips for using Item-level alternates 
 Plan your alternate sets in advance to avoid surprises 
 Item level alternates must be within the same category if categories are used. 
 Leave the Category-level Alternate Code blank unless you are also using alternate 

categories 
 Common Items do not receive alternate codes.   
 You can make one item alternate to two (or more) items 

 

Steps: 

Create a snapshot to back up your Job 

Open the Job and go to the “Items” tab 
1) Select or enter the first item(s) in the Alternate set. 

a) Set the Item Alternate Code to indicate the alternate set (e.g. “AA1”) 
2) Select or enter the second item(s) in the Alternate set  

a) Set the Item Alternate Code to indicate that this is the alternative item within the alternate 
set (e.g. “AA2”) 

3) Continue until you have designated all alternate items 

Tips for using Item-level alternates 
• Plan your alternate sets in advance to avoid surprises 
• Item level alternates must be within the same category if categories are used. 
• Leave the Category-level Alternate Code blank unless you are also using alternate categories 
• Common Items do not receive alternate codes.   
• You can make one item alternate to two (or more) items and vice-versa. 
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Setting Up CES Estimates for Option Bidding 
 
Option bidding forces the bidder to choose among alternatives by only allowing the bidder to bid on 
one of the available options. 
 
Option bidding is used when the two alternatives are to be compared solely on the basis of price 
without value adjustments or evaluation factors. 

Category Level Options 
Category Level options are used when entire groups of items are options to other groups of items,  or 
when the two groups of items represent alternative categories of work, such as option pavement 
sections (asphalt vs. concrete)  or option bridge designs (concrete vs. steel). 
 
Basic principles: 

o All Common Items will be in Category 0001 
o All items related to the first Option will be in Category 0002 
o All items related to the second Option will be in Category 0003  
o Option sets are distinguished by three character Alternate Code where he first two characters 

are letters defining the option set (OP, OB, etc) and the third character is a number designating 
the set member (1, 2, etc.) so OA1 is an option to OA2 and OB1 is an option to OB2, but OA1 is 
not an option to OB2.  

o The first character of the Alternate Code must be “O” to define an option set. 
o CES will use the lower cost option for each option set when totaling the estimate.  So if your 

estimate contains more than one option sets the final estimate will be the cost of common 
items + the lower cost option of the first option set + the lower cost option of the second 
option set and so on. 

o The CES Estimate Item Total (as shown on reports and the item tab) will always be the total of 
all items regardless of option status.  The Inflated Estimate Total & Total Estimate are adjusted 
to account for alternatives as well as inflation and contingency. 

Steps: 

Create a Separate Category for Each Option 

Make a backup snapshot of your Job 

Open the Job and go to the “Categories” tab 
 Select Category 0001 and choose “Hide/Show Details” to expand the detail section. 
 Edit the Category Description to specify Common Items (e.g. “Road Construction – Common 

Items” or “Bridge Construction – Common Items”).    
 Leave the Alternate Code field blank to indicate that this category is common to both 

options. 
 Select “Add” from the Edit menu to create Category 0002. 
 Edit the Category Description to specify the second option (e.g. “Road Construction – PCCP” 

or “Bridge Construction – Concrete”.    
 Set the Alternate Code to “OP1” for an optional pavement or “OB1” for an option bridge.  
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 Select “Add” from the Edit menu to create Category 0003. 
 Edit the Category Description to specify the first option (e.g. “Road Construction – HMA” or 

“Bridge Construction – Steel”. 
 Set the Alternate Code to “OP2” for an optional pavement or “OB2” for an optional bridge. 

Now go to the “Items” tab and assign each item to a Category (Option) as necessary by 
selecting the appropriate category in the Category field. 

Tips for using Category-level options 
 All items must be assigned to a Category – either one of the alternates or to the common 

items. 
 Leave the item-level Alternate Code blank unless you are also using alternate items within a 

category. 
 You may have as many as 26 Alternate sets (OA-OZ) 
 Use mnemonic codes for alternate sets (“OP” for optional pavements, “OB” for optional 

bridges, “OS” for alternate subbases, etc.) when possible 
 You can have as many as nine optional categories within each option set. 
 Assign the full quantities of all items needed to construct each option to the applicable 

option set.  Do not split out items between sets.  
 Assign all items common to both options to the common items category. 

Item Level Options 
Item level options are used when specific items on the project are considered options to other specific 
items, such as lamp poles. 
 
Basic principles: 

o Item level options will only be used when specific items are options to other specific items. 
o All optional items must have a counterpart item or item(s).  You cannot make nothing an 

alternative to something.  
o The optional items that receive the lowest bid prices will always be considered part of the 

awarded bid.  We cannot cherry pick options when awarding a contract.   
o CES will use the lower cost option when totaling the estimate. 
o Option sets are distinguished by three character code where he first two characters are letters 

defining the set (OP, OB, etc) and the third character is a number designating the set member 
(1, 2, etc).  So OA1 is an alternative to OA2 and OB1 is an Alternative to OB2, but OA1 is not an 
alternative to OB2 

o The first character of the Alt Code must be “O” to define an option set 
 

Steps: 

Make a backup snapshot of your Job 

Open the Job and go to the “Items” tab 
 Select or enter the first item for the option set. 
 Set the Item Alt Code to indicate that this item is part of an  option set (e.g. “OA1”) 
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 Select or enter the optional item for the option set. 
 Set the Item Alt Code to indicate that this item is the alternative within the option set (e.g 

“OA2”) 
 Continue until you have designated all option items 
 You must use “O” as the first letter to indicate that this is an option set 

Tips for using Item-level options 
 Plan your option sets in advance to avoid surprises 
 Item level options must be within the same category if categories are used. 
 Leave the Category-level Alternate Code blank unless you are also using option categories 
 Common Items do not receive Alt Codes.   
 You can make one item option to two (or more) items 

•  
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